SunRISE Users

Cross Posting Financial Services Announcement

Effective November 11, 2019, SunRISE will no longer function in Internet Explorer (IE) versions 6-10.  If you currently use IE as your browser, please open IE and click on “Help” at the top of your screen, and then click on “About Internet Explorer” to identify the version.

If you need to update your IE version, please contact your departmental IT support staff.